Security Policy

Supported Versions

Version Supported Notes
4.x
3.14.x Until 2020-06-30
3.12.x Until 2021-12-31 Android 2.3+ (API level 9+) and Java 7+. Platforms may not support TLSv1.2.

Reporting a Vulnerability

Square recognizes the important contributions the security research community can make. We therefore encourage reporting security issues with the code contained in this repository.

If you believe you have discovered a security vulnerability, please follow the guidelines at https://bugcrowd.com/squareopensource